Manager SE specific technical issues

Manufacture date

Manufacture date

Postby brianp87 » Mon Dec 19, 2016 12:28 pm

I've noticed for a while and keep forgetting to ask. The manufacture dates are not printing correctly on the tech sheets after I updated to the version 7.1.2. I can post pics if needed.
User avatar
brianp87
2.5K Uber Ninja Contributor
2.5K Uber Ninja Contributor
 
Posts: 2945
Joined: Tue Oct 10, 2006 6:11 am
Location: Arizona

Re: Manufacture date

Postby ricmorin » Mon Dec 19, 2016 3:20 pm

I'm not seeing any issues here. Can you post a pic of the problem? Also, which worksheet are you using?
Ric Morin - Volunteer Forum Moderator, Shop Owner, ASE Master L1
Motorcar Alternatives, LLC
603-622-6434
https://www.facebook.com/motorcaralternatives

Reality continues to ruin my life.- Calvin
User avatar
ricmorin
5K Holy Smokes Contributor
5K Holy Smokes Contributor
 
Posts: 5055
Joined: Mon Jul 25, 2005 10:11 am
Location: New Hampshire

Re: Manufacture date

Postby brianp87 » Mon Dec 19, 2016 3:28 pm

I can post more if needed.
Attachments
mitch 1.JPG
 
mitch 2.JPG
 
mitch 3.jpg
 
User avatar
brianp87
2.5K Uber Ninja Contributor
2.5K Uber Ninja Contributor
 
Posts: 2945
Joined: Tue Oct 10, 2006 6:11 am
Location: Arizona

Re: Manufacture date

Postby ricmorin » Mon Dec 19, 2016 3:36 pm

Check your date format on that computer. Do you have another computer and does it appear the same?

There was a date formatting fix introduced in 7.1.4 that might address this issue if your computer formatting is ok.
Ric Morin - Volunteer Forum Moderator, Shop Owner, ASE Master L1
Motorcar Alternatives, LLC
603-622-6434
https://www.facebook.com/motorcaralternatives

Reality continues to ruin my life.- Calvin
User avatar
ricmorin
5K Holy Smokes Contributor
5K Holy Smokes Contributor
 
Posts: 5055
Joined: Mon Jul 25, 2005 10:11 am
Location: New Hampshire

Re: Manufacture date

Postby brianp87 » Mon Dec 19, 2016 4:03 pm

I am not sure what you mean. I input the dates manually. I did notice that since the update it is a little different to input could it be I have to now use the drop down menu as opposed to entering the date as I have in years prior. I used to be able to tab through and I know I can no longer do that.
User avatar
brianp87
2.5K Uber Ninja Contributor
2.5K Uber Ninja Contributor
 
Posts: 2945
Joined: Tue Oct 10, 2006 6:11 am
Location: Arizona

Re: Manufacture date

Postby brianp87 » Mon Dec 19, 2016 4:08 pm

I just found one were its blank on the tech sheet but inputed on the vehicle.
Attachments
mitch 1.JPG
 
mitch 2.jpg
 
User avatar
brianp87
2.5K Uber Ninja Contributor
2.5K Uber Ninja Contributor
 
Posts: 2945
Joined: Tue Oct 10, 2006 6:11 am
Location: Arizona

Re: Manufacture date

Postby ricmorin » Tue Dec 20, 2016 4:19 am

I'm fairly sure this is addressed in 7.1.4.
Ric Morin - Volunteer Forum Moderator, Shop Owner, ASE Master L1
Motorcar Alternatives, LLC
603-622-6434
https://www.facebook.com/motorcaralternatives

Reality continues to ruin my life.- Calvin
User avatar
ricmorin
5K Holy Smokes Contributor
5K Holy Smokes Contributor
 
Posts: 5055
Joined: Mon Jul 25, 2005 10:11 am
Location: New Hampshire

Re: Manufacture date

Postby brianp87 » Tue Dec 20, 2016 5:57 am

Thank you.
User avatar
brianp87
2.5K Uber Ninja Contributor
2.5K Uber Ninja Contributor
 
Posts: 2945
Joined: Tue Oct 10, 2006 6:11 am
Location: Arizona

Re: Manufacture date

Postby Silky7 » Tue Dec 20, 2016 9:19 am

ricmorin wrote:Check your date format on that computer. Do you have another computer and does it appear the same?

There was a date formatting fix introduced in 7.1.4 that might address this issue if your computer formatting is ok.


brianp87,

The concern here is your current system time and date format isn't correct. E.g., it might be set to YY/MM/DD or something odd. We can help you check that if you need to on a call to support.
User avatar
Silky7
2nd Level Tech Support
2nd Level Tech Support
 
Posts: 632
Joined: Mon Dec 31, 2007 10:07 am

Re: Manufacture date

Postby Johnny5 » Tue Dec 20, 2016 11:47 am

It's in the report, the formatting of the date string done by crystal report is the culprit.

This:
if IsNull({TechWorksheetInfo.MfgDate}) then
date(0,0,0)
else
DTStoDate({TechWorksheetInfo.MfgDate})

Should be:
if IsNull({TechWorksheetInfo.MfgDate}) then
" "
else
Totext ({TechWorksheetInfo.MfgDate})

I will report the problem to development. I will also endeavor to put a patch on M1Files

JD
John Dwulet AKA: Johnny5
Sr. Product Marketing Manager - Mitchell1
Tuck in behind me, I'll show you where to crash. 8)
User avatar
Johnny5
System Guru / Moderator
System Guru / Moderator
 
Posts: 635
Joined: Wed May 26, 2004 2:03 pm
Location: Mitchell 1 John Dwulet, Sr. Product Marketing Manager

Re: Manufacture date

Postby brianp87 » Tue Dec 20, 2016 12:36 pm

Great thank you
User avatar
brianp87
2.5K Uber Ninja Contributor
2.5K Uber Ninja Contributor
 
Posts: 2945
Joined: Tue Oct 10, 2006 6:11 am
Location: Arizona

Re: Manufacture date

Postby Rich » Tue Dec 20, 2016 1:32 pm

This:
if IsNull({TechWorksheetInfo.MfgDate}) then
date(0,0,0)
else
DTStoDate({TechWorksheetInfo.MfgDate})

Should be:
if IsNull({TechWorksheetInfo.MfgDate}) then
" "
else
Totext ({TechWorksheetInfo.MfgDate})

Just what I thought it was! :lol:
Rich Hays
Supporter of Project Semicolon
231-796-0550 work
User avatar
Rich
3K Time Lord Contributor
3K Time Lord Contributor
 
Posts: 3640
Joined: Tue Sep 06, 2005 10:16 am
Location: Big Rapids, Mich

Re: Manufacture date

Postby brianp87 » Tue Dec 20, 2016 3:50 pm

Rich wrote:This:
if IsNull({TechWorksheetInfo.MfgDate}) then
date(0,0,0)
else
DTStoDate({TechWorksheetInfo.MfgDate})

Should be:
if IsNull({TechWorksheetInfo.MfgDate}) then
" "
else
Totext ({TechWorksheetInfo.MfgDate})

Just what I thought it was! :lol:


Its Spanish to me
User avatar
brianp87
2.5K Uber Ninja Contributor
2.5K Uber Ninja Contributor
 
Posts: 2945
Joined: Tue Oct 10, 2006 6:11 am
Location: Arizona

Re: Manufacture date

Postby Rich » Wed Dec 21, 2016 4:54 am

Yah, I was thinking someone spilled his bowl of Alphabet soup on the key board. This is a reason I laugh when we ask something "simple" to be done. Most have no clue what has to be done to make it work.
Rich Hays
Supporter of Project Semicolon
231-796-0550 work
User avatar
Rich
3K Time Lord Contributor
3K Time Lord Contributor
 
Posts: 3640
Joined: Tue Sep 06, 2005 10:16 am
Location: Big Rapids, Mich

Re: Manufacture date

Postby Johnny5 » Wed Dec 21, 2016 9:00 am

Just in time for Christmas... here are both tech worksheets with the MFG fixed. http://www.m1faqs.com/fix/SE/TechWorksheets.exe

Happy Holidays,

JD
John Dwulet AKA: Johnny5
Sr. Product Marketing Manager - Mitchell1
Tuck in behind me, I'll show you where to crash. 8)
User avatar
Johnny5
System Guru / Moderator
System Guru / Moderator
 
Posts: 635
Joined: Wed May 26, 2004 2:03 pm
Location: Mitchell 1 John Dwulet, Sr. Product Marketing Manager

Re: Manufacture date

Postby brianp87 » Wed Dec 21, 2016 9:50 am

Awesome as always great support. Merry Christmas.
User avatar
brianp87
2.5K Uber Ninja Contributor
2.5K Uber Ninja Contributor
 
Posts: 2945
Joined: Tue Oct 10, 2006 6:11 am
Location: Arizona

Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 1 guest